Bus #19 = Sub Driver, running late
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Dec 03, 2021 - 09:12 EST
Update
We are continuing to monitor for any further issues.
Posted Dec 03, 2021 - 06:51 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2021 - 06:01 EST
This incident affected: Transportation (Bus 19).