Bus #39 Elem students is on Bus #42. Bus #39 and Bus #42 MS and HS will ride together on Bus #42
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted May 24, 2022 - 08:52 EDT
Investigating
We are currently investigating this issue.
Posted May 24, 2022 - 06:05 EDT
This incident affected: Transportation (Bus 39, Bus 42).