Buses 5 & 29 will be combined on bus 29 for CHS (Possible Delays) 9/6/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 05:23 EDT
Monitoring
Bus 29 will be 1st load
Bus 5 will be 2nd load
Posted Sep 06, 2024 - 12:58 EDT
This incident affected: Transportation (Bus 05, Bus 29).