BUS 21 IS LEAVING THE LOT AT 6:25...BETHANY ROUTE WILL BE 30 MINUTES LATE
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 29, 2022 - 07:26 EDT
Investigating
We are currently investigating this issue.
Posted Sep 29, 2022 - 06:22 EDT
This incident affected: Transportation (Bus 21).