Bus # 200 = Bus 39 running 8 to 10 minutes behind

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 23, 2023 - 09:44 EDT

Investigating

We are currently investigating this issue.
Posted Mar 23, 2023 - 07:05 EDT