Bus 32 OMS/CHS with Sub Bus 508-0189 (Bus 17), expect delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 17:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2022 - 13:30 EDT
This incident affected: Transportation (Bus 17, Bus 32).