Bus #43 will transport Bus#41 and Bus #43 OES students
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted May 17, 2022 - 09:03 EDT
Investigating
We are currently investigating this issue.
Posted May 17, 2022 - 05:50 EDT