Bus 49 will be split between buses 27 & 46 for OMS & CHS (Possible Delays) 3/7/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 07, 2025 - 17:47 EST

Update

The Bluffs will be on bus 46
The Landings will be on bus 27
Posted Mar 07, 2025 - 13:42 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2025 - 13:41 EST
This incident affected: Transportation (Bus 27, Bus 46, Bus 49).