Bus #14 and Bus #22 will be combined for Elem. Bus #14 will be load #1. Middle School and High School students at the Ormand Rd stops will be on Bus #9
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 05:39 EDT
Investigating
We are currently investigating this issue.
Posted Apr 12, 2024 - 12:44 EDT
This incident affected: Transportation (Bus 14, Bus 22).