Buses 12 & 13 will be combined on bus 13 for CMS (Possible Delays) 3/26/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 17:40 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2025 - 13:21 EDT
This incident affected: Transportation (Bus 12, Bus 13).