Buses 12 & 22 are combined on bus 12 for GES & CHS/NGC (Possible Delays) 4/26/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 15:12 EDT
Monitoring
Students who live on Ormand Rd will ride bus 20 for CMS & CHS/NGC
Posted Apr 26, 2024 - 12:28 EDT
This incident affected: Transportation (Bus 09, Bus 12, Bus 22).