Bus 3, 9, 10, 23, 26 & 47 has a sub driver (Possible Delays) 10/21/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 21, 2024 - 09:19 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2024 - 06:37 EDT
This incident affected: Transportation (Bus 03, Bus 09, Bus 10, Bus 23, Bus 26, Bus 47).