Bus #41 and Bus #39 will be combined on Bus #41 for Elementary School. Bus #37 and Bus #39 will be combined on Bus #37 for Middle School and Bus #42 and Bus#39 will be combined on Bus #42 for High School
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 05:38 EDT
Investigating
We are currently investigating this issue.
Posted Apr 12, 2024 - 12:49 EDT
This incident affected: Transportation (Bus 37, Bus 39, Bus 41, Bus 42).