Bus 3, 19, 29 & 35 has a sub driver (Possible Delays) 12/11/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Dec 11, 2024 - 11:31 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2024 - 05:35 EST
This incident affected: Transportation (Bus 03, Bus 19, Bus 29, Bus 35).