BUS 31 I RUNNING 20-25 MINUTES LATE BETHANY ROUTE
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 29, 2022 - 07:36 EDT
Update
We are continuing to investigate this issue.
Posted Sep 29, 2022 - 06:59 EDT
Update
We are continuing to investigate this issue.
Posted Sep 29, 2022 - 06:58 EDT
Investigating
We are currently investigating this issue.
Posted Sep 29, 2022 - 06:38 EDT
This incident affected: Transportation (Bus 31).