Bus #22 Sub Driver for Elementary. Bus #25 and Bus #23 will take their students plus Bus #22's for Middle School and High School. Possible delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 08:52 EST
Investigating
We are currently investigating this issue.
Posted Jan 14, 2022 - 06:19 EST
This incident affected: Transportation (Bus 22, Bus 23, Bus 25).