BUS 45 IS ON BUS 5
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 05:47 EDT
Investigating
We are currently investigating this issue.
Posted Oct 03, 2022 - 05:27 EDT
This incident affected: Transportation (Bus 05).