Bus #14 down - Bus #22 will be picking up for Middle school only
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 08:50 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 14, 2022 - 07:39 EST
This incident affected: Transportation (Bus 14).