Expect Delays: Buses 57 is running about 20-30 minutes behind 1/9/26

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 09:33 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2026 - 06:22 EST
This incident affected: Transportation (Bus 57).