The following buses will be combined for CHS (Possible Delays) 12/5/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 17:43 EST

Monitoring

Buses 27 & 50 will be combined on bus 27
Buses 35 & 48 will be combined on bus 35
Posted Dec 05, 2025 - 13:38 EST
This incident affected: Transportation (Bus 27, Bus 35, Bus 48, Bus 50).