Expect Delays: Bus 37 & 48 is running about 15-20 minutes behind 8/8/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Aug 08, 2025 - 09:30 EDT

Update

We are continuing to monitor for any further issues.
Posted Aug 08, 2025 - 07:40 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 08, 2025 - 06:58 EDT
This incident affected: Transportation (Bus 37, Bus 48).