Bus 48 will be 2nd load on bus 35 for CCES (Possible Delays) 12/5/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 17:44 EST

Monitoring

Bus 35 will be 1st load
Bus 48 will be 2nd load
Posted Dec 05, 2025 - 13:33 EST
This incident affected: Transportation (Bus 35, Bus 48).