Bus 53 will be a 2nd load on bus 34 for CMS (Expect Delays) 5/15/26

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted May 15, 2026 - 18:23 EDT

Monitoring

Bus 34 will be 1st load
Bus 53 will be 2nd load
Posted May 15, 2026 - 13:42 EDT
This incident affected: Transportation (Bus 34, Bus 53).