Bus 9 CMS = will be split between Bus 47 & Bus 34, expect delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 17:50 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2022 - 14:13 EDT
This incident affected: Transportation (Bus 09, Bus 34, Bus 47).