Bus 15 will be split between buses 3, 11, 21 & 31 for Bethany, CMS & CHS/NGC (Possible Delays) 4/23/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 17:34 EDT
Monitoring
Students who live on Henry Knob Rd & Knox Rd will ride bus 3
Students who live on Agony Acres Rd, Beamguard Rd, & Davis Cir Frontier, Wilmoth will ride bus 31
Students who live on Lloyd White, Whiteside's, Windsong, Lilly Dr, Robinson Yelton, and Crowders Creek Rd will ride on bus 11
Students who live on Laurelwood Dr, Shepherd Ln & 1961 Hwy 55 will ride bus 21
Posted Apr 23, 2024 - 14:28 EDT
This incident affected: Transportation (Bus 03, Bus 11, Bus 15, Bus 21, Bus 31).