Bus 28 will be about 10 minutes early and will be on bus 14 4/26/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 09:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2024 - 05:25 EDT
This incident affected: Transportation (Bus 28).