Bus 19 possible delays (sub Driver) CCE OMS CHS

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 07:53 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 12, 2025 - 14:02 EDT
This incident affected: Transportation (Bus 19).