Bus 49 will be split between buses 27 & 46 for OMS & CHS (Possible Delays) 12/3/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 05:28 EST
Investigating
The Landings will ride bus 27
The Bluffs will ride bus 46
Posted Dec 03, 2024 - 13:48 EST
This incident affected: Transportation (Bus 27, Bus 46).