Bus 9 CMS will be split between Bus 16 or 12, expect delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 05, 2022 - 08:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 05, 2022 - 06:04 EDT
This incident affected: Transportation (Bus 09, Bus 16, Bus 12).