Bus 49 will be split between buses 25, 27 & 46 for OES, OMS & CHS (Possible Delays) 9/10/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 11, 2024 - 05:22 EDT
Monitoring
The Landings will ride bus 25 for OES & bus 27 for OMS & CHS
The Bluffs will ride bus 46 for OES, OMS & CHS
Posted Sep 10, 2024 - 13:53 EDT
This incident affected: Transportation (Bus 25, Bus 27, Bus 49).