Bus 26, 30, 40 & 53 has a sub driver (Possible Delays) 3/31/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 05:42 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2025 - 13:24 EDT
This incident affected: Transportation (Bus 26, Bus 30, Bus 40, Bus 53).