Bus 12, 13, 19, 21, 29, 49 & 57 has a sub driver (Possible Delays) 3/25/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 05:50 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 13:46 EDT
This incident affected: Transportation (Bus 12, Bus 13, Bus 19, Bus 21, Bus 29, Bus 49, Bus 57).