Bus 20 = Sub Driver, running about 10 minutes behind
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 17:49 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 03, 2022 - 14:21 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2022 - 14:19 EDT
This incident affected: Transportation (Bus 20).