Buses 35 & 48 will be combined on bus 48 for CCES, OMS, CHS (Possible Delays) 2/5/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 05:23 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2025 - 13:43 EST
This incident affected: Transportation (Bus 35, Bus 48).