Bus #2 will be spilt between Bus #1, Bus #7, Bus 29 and Bus #3
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 17:20 EST
Investigating
We are currently investigating this issue.
Posted Jan 14, 2022 - 14:00 EST
This incident affected: Transportation (Bus 02).