Buses 9 & 24 will be combined on bus 24 for CMS (Possible Delays) 9/2/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 06:36 EDT

Monitoring

Bus 24 will be 1st load
Bus 9 will be 2nd load
Posted Sep 02, 2025 - 13:47 EDT
This incident affected: Transportation (Bus 09, Bus 24).