Bus 6, 14, 46 & 53 has a sub driver (Possible Delays) 3/28/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 09:28 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2025 - 05:33 EDT
This incident affected: Transportation (Bus 06, Bus 14, Bus 46, Bus 53).