Bus #32 will be picked up by Bus #17 and Bus #16
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 08:51 EST
Investigating
We are currently investigating this issue.
Posted Jan 14, 2022 - 06:21 EST
This incident affected: Transportation (Bus 32).