Bus #32 will not be on Campus - Bus #17 and Bus #16 will be picking up their own students plus Bus #32 students. Expect delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 13, 2022 - 09:07 EST
Update
We are continuing to investigate this issue.
Posted Jan 13, 2022 - 06:14 EST
Update
We are continuing to investigate this issue.
Posted Jan 13, 2022 - 06:12 EST
Investigating
We are currently investigating this issue.
Posted Jan 13, 2022 - 05:54 EST
This incident affected: Transportation (Bus 16, Bus 17, Bus 32).