BUS 31 HAS A SUB DRIVER-EXPECT A DELAY OF 10-15 MINUTES
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 09:23 EDT
Investigating
We are currently investigating this issue.
Posted Sep 28, 2022 - 06:04 EDT
This incident affected: Transportation (Bus 31).