Bus 49 will be split for OMS & CHS (Possible Delays) 8/28/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 06:50 EDT
Monitoring
The Bluffs will ride bus 46 for OMS & CHS
The Landings will ride bus 50 for OMS & CHS
Posted Aug 28, 2024 - 13:57 EDT
This incident affected: Transportation (Bus 46, Bus 49, Bus 50).