Bus#11 - Running 10-15 minutes behind for High School. Please report to your stop normal time but there may be a delay.
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 08:53 EST
Investigating
We are currently investigating this issue.
Posted Jan 14, 2022 - 08:16 EST
This incident affected: Transportation (Bus 11).