Buses 1 & 36 will combined on bus 36 for OMS & CHS (Possible Delays) 3/19/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 05:28 EDT

Monitoring

Marlin will be on bus 50 for OMS & CHS
The Revere will be on bus 32 for OMS & CHS
Posted Mar 19, 2025 - 13:42 EDT
This incident affected: Transportation (Bus 01, Bus 36).